[ << ] [ >> ]           [Top] [Contents] [Índice] [ ? ]

7. Editando

Editar envolve tanto o domínio das trilhas quanto do tempo. Uma vez que a linha do tempo consiste em um conjunto de trilhas, você precisa se preocupar em como criar e ordenar trilhas além de quando certas mídias aparecem em uma trilha.

No domínio de tempo, o Cinelerra oferece muitas abordagens para o processo de edição. Os três métodos principais são edição com dois monitores, edição de arrastar e soltar e edição de recortar e colar.

Há vários conceitos que o Cinelerra usa quando edita que se aplicam a todos os métodos.

A linha do tempo é onde todas as decisões de edição são representadas. Ela é um conjunto de trilhas no meio da janela principal. Ela pode ser rolada para cima e para baixo, esquerda e direita com as barras de rolagem à direita e abaixo dela. Ela também pode ser rolada para cima e para baixo com a rodinha do mouse, ou para a esquerda e direita, com a rodinha do mouse e a tecla CTRL.

A região ativa é a abrangência de tempo que será afetada pelos comandos de edição na linha do tempo. A região ativa é determinada primeiro pela presença de pontos de entrada/saída na linha do tempo. Caso eles não existam, a área em destaque será usada. Caso não exista uma área destacada, o ponto de inserção será usado como o início da região ativa. Alguns comandos tratam todo o espaço à direita do ponto de inserção como ativo enquanto outros tratam a abrangência ativa como 0 se nenhum ponto de término para a região ativa for definido.

Finalmente, decisões de edição nunca afetam o material fonte. Isso chama-se edição não-destrutiva e tornou-se popular com o áudio porque era muito mais rápida do que se você tivesse que copiar toda a mídia afetada por uma edição. Editar afeta apenas apontadores para o material fonte, então se você quiser ter um arquivo de mídia ao final de sua sessão de edição que represente suas decisões de edição, você precisa fazer um render. See section Renderizando arquivos. See section Salvando arquivos de projeto.


7.1 O patchbay

À esquerda de linha do tempo está uma região afetuosamente conhecida como o patchbay. O patchbay habilita funções específicas para cada trilha.

Todas as trilhas têm uma área de texto para nomear a trilha.

Todas as trilhas possuem um expandidor manual_images_intl/expandpatch_checked para ver mais opções no patchbay e para ver os efeitos representados na trilha. Clique na seta para expandir ou encolher o patchbay e a trilha. Caso esteja apontando para o lado, a trilha está encolhida. Caso esteja apontando para baixo, a trilha está expandida. Efeitos existentes aparecem abaixo da mídia daquela trilha, caso existam.

Todas as trilhas possuem a seguinte lista de habilitações para várias funções.

manual_images_en/track_attributes

Atributos de trilha

Se o botão que habilita a função estiver colorido, a função estará habilitada. Se ele estiver com a mesma cor do fundo da maioria das janelas, ele está desabilitado. Clique no botão para habilitar ou desabilitar a função. Várias operações de mouse aceleram a configuração de várias trilhas ao mesmo tempo.

Clique em um atributo e arraste o cursor por trilhas adjacentes para copiar o mesmo atributo para essas trilhas.

Mantenha o SHIFT pressionado enquanto clica em um atributo de uma trilha para habilitá-lo na trilha atual e desabilitá-lo em todas as outras trilhas.

Mantenha o SHIFT pressionado enquanto clica em um atributo. Clique até que todas as outras trilhas que não a selecionada estejam desabilitadas. Arraste então o cursor por sobre a trilha adjacente para habilitar o atributo na trilha adjacente.

Atributos que afetam a saída da trilha:


7.2 Empurrando trilhas

Cada trilha possui uma caixa de texto de deslocamento ("nudge") em seu patchbay. Você deve ter que expandir a trilha para vê-la. Essas são as imagens do patchbays quando expandido.

manual_images_en/apatches

Fazendo panorâmica e deslocamento para uma trilha de áudio

manual_images_en/vpatches

Modo de sobreposição e deslocamento para uma trilha de vídeo

O valor do deslocamento ("nudge") é o quanto a trilha é empurrada para a esquerda ou direita durante a reprodução. A trilha não é disposta deslocada na linha do tempo, mas é deslocada quando é reproduzida. Isso é útil para sincronizar áudio com vídeo, criar um falso estéreo ou compensar um efeito que modifica o tempo, tudo sem modificar os blocos de edição.

Apenas informe a quantidade de tempo para ser deslocada para deslocar imediatamente a trilha. Números negativos fazem a trilha ser reproduzida com atraso. Números positivos fazem com que seja reproduzida com antecedência. As unidades de deslocamento ("nudge") são tanto segundos ou as unidades nativas para a trilha (quadros ou amostragem). Selecione as unidades clicando com o botão direito do mouse na caixa de texto de deslocamento e selecione a partir do menu.

Configurações de deslocamento são agrupadas com a função Agrupar faders e a função Armar trilha.

Use a rodinha do mouse por sobre a caixa de texto de deslocamento para aumentar ou diminuir o número ali.


7.3 Fazendo um pan nas trilhas de áudio

Trilhas de áudio possuem uma caixa de pan em seu patchbay. Você pode ter que expandir a trilha para vê-la. A caixa de pan é mostrada aqui.

manual_images_en/apatches

Fazendo panorâmica e deslocamento para uma trilha de áudio

Posicione o apontador na caixa de pan e clique/arraste-o para reposicionar a saída de áudio conforme o arranjo dos falantes. A altura de cada falante é impressa em seu ícone respectivo durante a operação de arraste. A caixa de pan usa um algoritmo especial para tentar permitir que o áudio seja focado através de um falante ou dividido entre os falantes mais próximos quando mais de 2 falantes estiverem sendo usados.


7.4 Pan automático de trilhas de áudio

Várias funções de conveniência são dadas para configurar automaticamente o pan para vários padrões comuns. Elas estão listadas no menu de Áudio. Estas funções afetam apenas as trilhas de áudio armadas. Elas são:

See section Atributos de áudio.


7.5 Mapeamentos padrão de áudio

Embora o Cinelerra permita que você mapeie qualquer trilha de áudio para qualquer falante, existem mapeamentos padrão que você pode usar para ter certeza de que a mídia possa ser reproduzida em outros lugares. Além disso, a maioria dos transcodificadores de áudio requerem que as trilhas de áudio sejam mapeadas para números padrão de falantes ou elas não funcionarão.

Na opção Posições dos canais de See section Atributos de áudio, os canais são numerados para corresponder às trilhas de saída para onde são renderizados. Para estéreo, a fonte do canal 1 requere ser a trilha da esquerda e a fonte do canal 2 precisa ser a trilha da direita.

Para som surround 5.1, as fontes dos 6 canais precisam estar na ordem centro, esquerda-frente, direita-frente, esquerda-trás, direita-trás, efeitos de baixa freqüência. Se as trilhas certas não forem mapeadas para os falantes certos, a maioria dos transcodificadores de áudio não codificarão a informação certa, se é que codificarão alguma coisa. A trilha para efeitos de baixa freqüência especificamente não pode armazenar freqüências altas na maioria dos casos.


7.6 Manipulando trilhas

As trilhas no Cinelerra contêm ou áudio ou vídeo. Não há designações especiais para trilhas além do tipo de mídia que contêm. Quando você cria um projeto, ele contém três trilhas padrão: uma trilha de vídeo e duas trilhas de áudio. Você ainda pode adicionar ou apagar trilhas a partir dos menus. O menu de Trilhas contém um número de opções para lidar com múltiplas trilhas simultaneamente. Cada trilha possui um menu que afeta apenas ela mesma. See section O menu relacionado às trilhas.

Operações no menu de Trilhas afetam apenas as trilhas que estiverem armadas:

Finalmente, você vai querer criar novas trilhas. Os menus de Áudio e Vídeo contêm uma opção cada para adicionar uma trilha daquele tipo específico. No caso de áudio, a nova trilha é colocada ao final da linha do tempo e o canal de saída da trilha de áudio é aumentado por um. No caso de vídeo, a nova trilha é colocada ao topo da linha do tempo. Desta forma, o vídeo possui uma ordem natural de composição. Novas trilhas de vídeo são sobrepostas ao topo das trilhas antigas.


7.7 Edição em duas janelas

Este é o jeito mais rápido de construir um programa a partir de arquivos de vídeo. A idéia consiste em ver um arquivo de vídeo em uma janela e ver o programa em outra janela. Subseções do arquivo de vídeo são definidas em uma janela e transferidas para o final do programa na outra janela.

O jeito de começar uma sessão de edição em duas janelas é carregar alguns recursos. Em Arquivo->Carregar, carregue alguns vídeos com o modo de inserção Criar novos recursos. Você vai querer que a linha do tempo permaneça sem modificações quando os novos recursos forem carregados. Vá para a Janela de Recursos e selecione a pasta Mídia. Os novos recursos, recém-carregados, devem aparecer. Arraste um recurso para a janela de Visualização.

Deve haver trilhas armadas o suficiente na linha do tempo para colocar as subseções do material-fonte que você quiser. Caso não haja, crie novas trilhas ou arme mais trilhas.

Na janela de Visualização, defina um recorte de seu arquivo de vídeo:

Os dois pontos devem agora aparecer na barra de tempo e definir um recorte.
Há várias coisas que você pode fazer com o recorte agora:

A edição em duas janelas pode ser feita inteiramente através de atalhos de teclado. Quando você move o apontador do mouse sobre qualquer botão, uma caixa de dica deve aparecer, mostrando qual tecla está relacionada àquele botão. Na janela de Visualização, as teclas do teclado numérico controlam o transporte e as teclas [ ] v executam pontos de entrada/saída e divisão.


7.8 Edição de arrastar e soltar

Edição de arrastar e soltar é uma forma simples e rápida de trabalhar com o Cinelerra, usando apenas o mouse. A idéia básica é criar um punhado de recortes e então arrastá-los na ordem para a linha do tempo, construindo um protótipo de filme que você possa assistir na janela de composição. Se após assisti-lo você decidir re-arranjar seus recortes, marcar efeitos, adicionar transições ou inserir/apagar material, só arraste-os e solte-os na linha do tempo.

  1. Carregue alguns arquivos usando Arquivo->Carregar.
  2. Marque o modo de inserção para Criar novos recursos apenas. Isso carregará os arquivos na Janela de Recursos.
  3. Crie algumas trilhas de vídeo e áudio na linha do tempo usando os menus de Vídeo e Áudio.
  4. Abra a pasta Mídia na janela de recursos.
  5. Certifique-se que as trilhas necessárias estejam armadas e arraste o arquivo de mídia da janela de recursos para a linha do tempo. Se a mídia possui vídeo, arraste-a para uma trilha de vídeo. Se a mídia for apenas áudio, arraste-a para uma trilha de áudio. Se a mídia for uma imagem estática, arraste-a para uma trilha de vídeo.

manual_images_intl/drag_to_program

O Cinelerra preenche as trilhas de áudio e vídeo abaixo do cursor que estiver arrastando as mídias com informações sobre o arquivo. Isso afeta que trilhas você deve criar inicialmente e para qual trilha você arrastará a mídia.
Para arrastar e soltar um arquivo na janela de Programa, você precisa criar na linha do tempo o mesmo conjunto de trilhas de seu arquivo de mídia.
Um arquivo comum de câmera possui um conjunto de uma trilha de vídeo e duas de áudio. Neste caso, você precisará de uma trilha de vídeo e duas trilhas de áudio e a mídia deverá ser arrastada por sobre a primeira trilha de vídeo.
Se a mídia for apenas de áudio, você precisará de uma trilha de áudio na linha do tempo para cada trilha de áudio na mídia, e a mídia deverá ser arrastada por sobre a primeira trilha de áudio.
Se a mídia for uma imagem estática, você precisará de uma trilha de vídeo apenas.

Quando você arrasta sua mídia escolhida da pasta de mídias para a linha do tempo, o apontador de seu mouse arrastará uma imagem miniatura e, uma vez sobre a linha do tempo, o contorno de um retângulo branco do tamanho do bloco de edição que você terá aparecerá.

Arraste a mídia para a posição desejada de uma trilha da linha do tempo e solte-a. Caso haja outros blocos de edição naquela trilha, quando você mover o contorno branco por sobre um bloco, você verá um símbolo de gravata-borboleta >< aparecendo nas bordas do bloco. Se você soltar a mídia ali, o novo bloco será iniciado a partir da borda indicada ao centro da gravata-borboleta ><.

Uma vez que o apontador do mouse estiver no meio do contorno branco, quando este retângulo for maior que a parte visível da linha do tempo, é bem difícil inseri-lo de modo preciso. (Isso provavelmente acontecerá a mídias grandes). Diminuir a duração visível da linha do tempo modificando a amostragem de aproximação no painel de aproximação reduzirá o tamanho do retângulo branco, fazendo com que uma inserção precisa seja possível.

Você também pode arrastar vários arquivos da janela de recursos. Quando jogados na linha do tempo, eles são concatenados.
O jeito de selecionar vários arquivos para arrastar mudanças vai depender se os recursos estiverem sendo exibidos como texto ou como ícones. Para mudar o modo de exibição, clique com o botão direito do mouse dentro da lista de mídia e selecione ou Exibir ícones ou Exibir texto.
Quando texto estiver sendo exibido na janela de recursos, clicar + usar o botão CTRL nos arquivos de mídia seleciona arquivos adicionais um por vez; clicar + usar o botão SHIFT nos arquivos de mídia extende o número de seleções destacadas.
Quando ícones estiverem sendo exibidos na janela de recursos, clicar + usar o botão SHIFT ou clicar + usar o botão CTRL seleciona os arquivos de mídia um por vez; desenhar uma caixa sobre os arquivos seleciona arquivos contíguos.

Além de arrastar arquivos de mídia, se você criar recortes e abrir a pasta recortes você pode arrastar recortes para a linha do tempo.

Na linha do tempo há funções extras de arraste. Arrastar blocos de edição pela linha do tempo permite que você ordene listas de reprodução de músicas, cenas de vídeos e gere demos do NAB melhores, mas não muito mais que isso. Para habilitar a função de arraste na linha do tempo, selecione o ícone de flecha manual_images_intl/arrow na barra de controle.

Arme uma trilha com várias cenas.

manual_images_intl/drop_before

Trilha original com três cenas.

Vá para a cena #3, clique e arraste-a para o meio.

manual_images_intl/drag_track

Quando você soltar a cena #3

manual_images_intl/drop_concept

a cena #2 muda para a direita.

manual_images_intl/drop_after

Assim é como a seqüência terminada fica.

Se mais de uma trilha estiver armada, o Cinelerra arrastará todos os blocos de edição que começam na mesma posição que o bloco onde o cursor do mouse está posicionado. Em outras palavras, você pode arrastar e soltar um grupo de blocos de edição. O Cinelerra reconhece como um grupo os blocos de trilhas diferentes armadas que possuem inícios alinhados, sejam eles da mesma fonte ou não, tendo finais alinhados ou não.

Quando você arrasta e solta blocos de edição dentro da linha do tempo:
Se você soltar um bloco quando as gravatas-borboletas >< estiverem sendo mostradas, ele será recortado e colado iniciando na borda de edição indicada ao centro da gravata ><. Os blocos de edição seguintes se moverão.
Se você soltar um bloco quando não há gravatas-borboleta >< sendo mostradas, o bloco original será mutado e colado onde você o largou. Nenhum bloco de edição se moverá. Um silêncio aparecerá no lugar de seu recorte original.
Se você possui mais trilhas armadas na linha do tempo além da qual você está arrastando, apenas os blocos seguintes das trilhas afetadas pela operação de arrastar e soltar se moverão para a direita. Isso causará a perda de sincronia. Para restaurá-la, desarme as trilhas afetadas pela operação de arrastar e soltar, destaque apenas o bloco recém solto e insira silêncio por sobre ele (Editar -> Inserir Silêncio).

No modo de arrastar e soltar, você não pode arrastar e soltar marcadores. Eles estarão sempre presos à barra do tempo, mesmo com a opção Editar marcadores habilitada. Ainda assim, com a opção Editar marcadores habilitada, se uma área selecionada de um recurso for dividida a partir do Visor para a linha do tempo em uma posição anterior aos marcadores, estes serão empurrados para a direita pela duração da área selecionada.

Com pontos de entrada/saída, você pode realizar operações de Recortar e Colar no modo de Arrastar e Soltar assim como faria no modo Recortar e Colar. Vá para o Menu Editar para ver a lista e os atalhos de teclado.


7.9 Edição de recortar e colar

Este é o método tradicional de edição nos editores de áudio.
No caso do Cinelerra, você pode copiar blocos de edição na mesma trilha, copiar a partir de diferentes trilhas na mesma instância, iniciar uma segunda instância do Cinelerra e copiar a partir de uma instância para a outra ou carregar um arquivo de mídia no Visor e copiá-la a partir dali.

Carregue alguns arquivos na linha do tempo. Para fazer a edição por recorte e cola, selecione o manual_images_intl/ibeam ícone da barra. Selecione a região da linha do tempo e selecione o manual_images_intl/cut botão de recorte para cortá-lo. Mova o ponto de inserção para outro ponto da linha do tempo e selecione manual_images_intl/paste o botão de colar. Assumindo que não haja pontos de entrada/saída definidos na linha do tempo, isso faz a operação de recortar e colar.

Se pontos de entrada/saída estiverem definidos, o ponto de inserção e a região em destaque serão sobrescritas pelos pontos de entrada/saída para as operações de prancheta ("clipboard"). Assim, com pontos de entrada/saída você pode fazer recorte e cola no modo de arrastar e soltar tanto quanto no modo de recortar e colar.

A maioria das operações está listada no menu Editar. Algumas possuem um botão na barra de ferramentas de controle do programa e um atalho de teclado.

Outras operações de edição:

No modo de Copiar e Colar, você também pode editar marcadores. Ao habilitar Editar marcadores no menu de configurações, ou ao desabilitar o botão de "Impedir marcadores de se mover" na barra de controle de ferramentas do programa, marcadores poderão ser cortados, copiados ou colados juntamente com as regiões selecionadas das trilhas armadas.

Quando estiver editando áudio, é comum recortar uma área da onda sonora para uma mesma área de outra onda sonora. Os pontos de início e final do recorte são idênticos em cada onda sonora e podem ser deslocados levemente caso a informação de onda seja diferente. Seria bem difícil destacar uma onda sonora e recortá-la e destacar a segunda onda sonora e colá-la sem mudar as posições relativas de início e final.
Uma alternativa para simplificar isso é abrir uma segunda cópia do Cinelerra, recortar e colar para transportar mídia entre as duas cópias. Desta forma, duas regiões destacadas podem existir simultaneamente.
Outra opção é marcar pontos de entrada/saída para a região fonte da onda sonora fonte e colocar marcadores para a região de destino da onda sonora de destino. Faça um recorte, limpe os pontos de entrada/saída, selecione as regiões entre os marcadores e faça a cola.


7.10 Redimensionando ("trimming")

Com alguns bloco de edição na linha do tempo, é possível fazer o redimensionamento. Por redimensionamento, você encolhe ou estica as bordas do bloco de edição ao arrastá-las. No modo de arrastar e soltar ou no modo de recortar e colar, mova o cursor para sobre a borda de um bloco de edição até que ele mude de forma. O cursor se tornará uma forma para expandir para a esquerda ou para a direita. Se o cursor for para expandir para a esuqerda, a operação de arrastar afeta o início do bloco de edição. Se o cursor for para expandir para a direita, a operção de arraste afeta o final do bloco de edição.

Quando você clica na orda de um bloco de edição para começar a arrastá-la, o número do botão do mouse determina qual o comportamento de arraste será usado. 3 comportamentos possíveis estão relacionados aos botões do mouse nas preferências de interface. See section Interface.

O efeito de cada operação de arraste não depende somente no comportamento do botão, mas se o começo ou final do bloco de edição é que está sendo arrastado. Quando você solta o botão do mouse, a operação de redimensionamento acontece.

Na operação Arrastar todas as edições seguintes, o começo do bloco de edição ou recorta informação do bloco se você movê-lo para frente ou cola nova informação de antes do recorte se você movê-lo para trás. O final do bloco cola informação no recorte se você movê-lo para frente ou corta informação do final do recorte se você movê-lo para trás. Todos os recortes a partir dali mudam. Finalmente, se você arrastar o final do recorte passando pelo começo do recorte, o bloco de edição é apagado.

Na operação Arrastar somente uma edição, o comportamento é o mesmo quando você arrasta o começo ou o final de um bloco de edição. Aúnica diferença é que nenhum dos outros blocos são mudados. Ao invés disso, tudo adjacente ao bloco atual expande ou encolhe para preencher buracos deixados pela operação de arraste.

Em uma operação Arrastar fonte somente, nada é recortado ou colado. Se você mover o início ou o final do bloco de edição para a frente, a fonte de referência no recorte é modificada para frente. Se você mover o início ou o final do bloco de edição para trás, a fonte de referência muda para trás. O lugar onde o recorte aparece na linha do tempo permanece o mesmo, mas a fonte muda.

Para todos os formatos exceto imagens estáticas, a extensão da operação de redimensionamento é limitada pela duração do arquivo de origem. Tentar arrastar o início de um recorte para além do início do material fonte não resultará em nada.

Em todas as operações de redimensionamento, todos os recortes que começam na mesma posição que o cursor quando a operação de arraste começar serão afetados. Desarme as trilhas para prevenir que os recortes sejam afetados.

A maioria dos efeitos do Cinelerra podem ser entendidos simplesmente usando-os e mexendo em suas propriedades. Aqui estão algumas breves descrições de efeitos que você pode não usar inteiramente simplesmente experimentando-os.


[ << ] [ >> ]           [Top] [Contents] [Índice] [ ? ]

This document was generated by Raffaella Traniello on Maio, 30 2008 using texi2html 1.76.